通达信板块显示主图公式,求在东方财富通主图上显示个股板块的公式

内容导航:
  • 求在东方财富通主图上显示个股板块的公式
  • 通达信 主图显示板块的指标
  • 请高手编一个:能显示所属板块指标的通达信主图公式,谢谢!
  • 如何在通达信公式显示所属行业和板块
  • 如何在通达信公式显示所属行业和板块
  • 通达信如何显示行业板块代码?
  • Q1:求在东方财富通主图上显示个股板块的公式


    将下面代码复制到主图公式里保存就可以了。

    DRAWTEXT_FIX(ISLASTBAR,0.01,0,0,GNBLOCK),COLORYELLOW;

    DRAWTEXT_FIX(1,0.01,0.05,0,HYBLOCK),COLORYELLOW;

    Q2:通达信 主图显示板块的指标

    系统设置--设置4--选取:使用通达信细分行业板块。就能在主图上显示个股所属板块了。

    Q3:请高手编一个:能显示所属板块指标的通达信主图公式,谢谢!

    {说明:通达信最新版可用}

    MA1:MA(CLOSE,5);

    MA2:MA(CLOSE,10);

    MA3:MA(CLOSE,20);

    MA4:MA(CLOSE,60);

    HH:=CONST(HHV(H,160));

    LL:=CONST(LLV(L,160));{160可改成你习惯锁定的日K线数}

    HL1:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.76,0.04));

    HL2:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.80,0.08));

    HL3:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.84,0.12));

    HL4:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.88,0.16));

    HL5:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.92,0.20));

    HL6:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.96,0.24));

    DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLOR0080FF;

    DRAWTEXT_FIX(1,0.07,0,0,HYBLOCK)COLOR0080FF;

    DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLOR00FFFF;

    DRAWTEXT_FIX(1,0.21,0,0,DYBLOCK)COLOR00FFFF;

    DRAWTEXT_FIX(1,0.00,0.04,0,'主题投资:')COLOR0000FF;

    DRAWTEXT_FIX(1,0.07,0.04,0,EXTERNSTR(0,1))COLOR0000FF;

    DRAWTEXT_FIX(1,0.00,0.08,0,'主营业务:')COLORFF00FF;

    DRAWTEXT_FIX(1,0.07,0.08,0,EXTERNSTR(0,2))COLORFF00FF;

    DRAWTEXT_FIX(1,0.00,0.12,0,'出千概念:')COLORFF88FF;

    DRAWTEXT_FIX(1,0.07,0.12,0,EXTERNSTR(0,3))COLORFF88FF;

    DRAWTEXT_FIX  (1,0.80,HL1,0,'股本:');

    DRAWNUMBER_FIX(1,0.84,HL1,0,CONST(FINANCE(1)/100000000));

    DRAWTEXT_FIX  (1,0.80,HL2,0,'流通:');

    DRAWNUMBER_FIX(1,0.84,HL2,0,CONST(FINANCE(7)/100000000));

    DRAWTEXT_FIX  (1,0.80,HL3,0,'动PE:');

    DRAWNUMBER_FIX(1,0.84,HL3,0,CONST(DYNAINFO(39)));

    DRAWTEXT_FIX  (1,0.80,HL4,0,'换手:');

    DRAWNUMBER_FIX(1,0.84,HL4,0,CONST(DYNAINFO(37)*100));

    DRAWTEXT_FIX  (1,0.80,HL5,0,'量比:');

    DRAWNUMBER_FIX(1,0.84,HL5,0,CONST(DYNAINFO(17)));

    DRAWTEXT_FIX  (1,0.80,HL6,0,'涨幅:');

    DRAWNUMBER_FIX(1,0.84,HL6,0,CONST(DYNAINFO(14)*100)),COLORFF00FF;

    DRAWNUMBER_FIX(1,0.84,HL6,0,IF(CONST(DYNAINFO(14)*100)<0,CONST(DYNAINFO(14)*100),DRAWNULL))COLOR00FF00;

    Q4:如何在通达信公式显示所属行业和板块

    在主图指标的源码里面,将所属板块和行业的代码编写进去即可。代码如下:
    DRAWTEXT_FIX(ISLASTBAR,0.3,0,0,HYBLOCK),COLORYELLOW;
    DRAWTEXT_FIX(ISLASTBAR,0.4,0,0,DYBLOCK),COLORYELLOW;
    DRAWTEXT_FIX(ISLASTBAR,0.5,0,0,GNBLOCK),COLORYELLOW;
    参考资料:http://tieba.baidu.com/p/2896773735

    Q5:如何在通达信公式显示所属行业和板块

    在主图指标的源码里面,将所属板块和行业的代码编写进去即可。代码如下:
    DRAWTEXT_FIX(ISLASTBAR,0.3,0,0,HYBLOCK),COLORYELLOW;
    DRAWTEXT_FIX(ISLASTBAR,0.4,0,0,DYBLOCK),COLORYELLOW;
    DRAWTEXT_FIX(ISLASTBAR,0.5,0,0,GNBLOCK),COLORYELLOW;
    参考资料:http://tieba.baidu.com/p/2896773735

    Q6:通达信如何显示行业板块代码?

    你的问题应该可以这样解决,如下图和代码

    股理乾坤为您解答

    DRAWTEXT_FIX(ISLASTBAR,0.05,0,0,HYZSCODE);

    DRAWTEXT_FIX(ISLASTBAR,0,0,0,HYBLOCK);

    上一篇:上一篇:抛售股票
    下一篇:下一篇:深南电b股票股吧
    • 评论列表

    发表评论: